Ensimmäinen…toinen..ja kolmas sahaus

Uusi video löytyy tuolta videot sivulta! Eilisiltana menikin sitten myöhään sahan kanssa leikkiessä. Pari kertaa meni lanka poikki ohjelman ajon aikana ja syyksi päättelin liian hitaan langannopeuden, sillä lanka oli kuin kuun pintaa mitä sitä läheltä katselin.

Sitten kun nostin tuota langannopeutta hieman, lanka ei mennyt enää poikki kuin siitä syystä, että alapuolen suuttimeen oli unohtunut kytkeä tuo huuhteluletku, jolloin levyn reunasta irronnut pieni pala tipahti siitä sisään ja kiilautui langanohjaimen ja langan väliin, jolloin vetomoottori rykäisi langan nätisti poikki. Näemmä kaikki pitää oppia kantapään kautta.

Myöhemmin testaillesa ihmettelin, että miksi saha lakkasi liikkumasta. Kipinöinti hetken jatkui ja sitten hiipui ja huomasin, ettei akselit liikkuneet lainkaan. Tätä oli joskus aikoinaan muinoinaan sattunut noiden askelmoottoreiden toimintaa testaillessa erillisillä komponenteilla ja epäilinkin siksi niiden virtalähteen kuntoa, se kun oli saanut siipeensä varmaankin ennen.

Virtalähde auki ja ihmettelemään. Mitään näkyviä vikoja ei ollut, virtalähdettä kuormittelin ihan mukavastikin ja jännitteet oli kuten pitikin, joten laitoin sen takaisin ja virrat päälle. Viiden sekunnin kuluttua virtojen päälle laittamisesta askelmoottoreiden ohjaimet löi suojaukset päälle ja yleismittarilla mitattu jännite näytti selvän notkahduksen ja tasaisen tippumisen.

Prkleen prkl. Noh, virittelin miljoonalaatikostani muuntajan, tasurin ja konkkia kasan pöydälle ja vetäisin piuhat askelmoottoriohjaimille. Kas kummaa, taas toimii eikä merkkiäkään sammumisesta. Taitaa tulla ostoslistalle uudet ohjaimet, sillä nämä ei suostu toimimaan 12 V:n moottorijänitteellä. Ajattelin meinaan päivittää tuon virtalähteen käyttämään ihan perus ATX:ää.

Pientä vikaa-kaa-kaa

Eilen hain täyden rullan lankaa (kiitokset TH-Tools!), jotta pääsin testaamaan ensimmäistä kertaa NC-ajoa kunnolla. Hyvin meni, hetken aikaa. Ihmetteln, että kun ei meinaa sahata niin kuin ennen sahasi ja teho tuntui puuttuvan kipinästä, kun meni niin hiljaa.

Noh, virtalähde auki ja mittailemaan. Kolme neljästä vastuksesta kärähtänyt poikki. Jaa mutta niin, 100 ohmisia ja 25 W tehonkestoa, olin alkujaan vain asentanut nämä protomielessä ja nehän sitten jäi. 60 VDC avoimella jännitteellä jaksoivat vielä, vaikka olikin ylikuormaa pahimmillaan 44 %, mutta minähän fiksuna poikana päivitin myöhemmin tuon jännitteen 100 VDC lukemaan. Hupsista, oikosulussa vastukseen hukkuikin nyt 100 W, eli ei ihme jos kärähtikin.

Siinä sitten heitin mäelle nuo palaneet ja pistin jäljelle jääneistä kuudesta vastuksestani yhden ison, 100 ohmia ja 150 W. Ei nyt sitten säätöä sen suhteen ole, mutta toimii ainakin. Isolle jäähylle ei ollut sisällä tilaa, joten jätin tuon jäähylevyn ulkopuolelle vastuksineen ja pistin vielä tuulettimen puhaltamaan jäähyn ripoihin.

Tuossa juotellessa piuhoja kiinni huomasin miksi se kipinän energiakin tuntui niin vähältä. Oli vissiin heikko juotos ollut, kun oli kytkimeltä irronnut yhden ison kondensaattorin (3.3 uF) piuha irronnut ja jäljellä oli vain 1 uF peruskonkka. Piuha uudelleen kiinni kunnolla ja tarkistus että muutkin on kiinni. Kansi päälle, omaiset ovat nähneet ja ruuvit kiinni.

Nyt sitten tätä kirjoittaessa saha tuossa suhisee ja pumput puhisee, leikkauksessa on NC-ajona kalanruoto 2 mm vahvasta ruostumattomasta teräksestä. Langan nopeus näyttäisi olevan suunnilleen 1.5 m/min, virtaa menee melkein ampeerin ja kipinävälin jännitteenä on 40 VDC. Vauhtia näyttäisi piisaavan keskimäärin1,5 -  2 mm/min. Kuvia ja päivitystä tilanteeseen luvassa illalla, ehkä myöskin uusi video :)

Motti kiinni, softan rakentelua

Pitkiä päiviä taas ollut ja vihdoin sain tuon uuden langanvetomoottorin asennettua ohjaimineen paikoilleen. Kirjoittelin tuosta tarkemmin Mekaniikka osion puolelle.

Seuraavaksi sitten olisi aiheena päivittää softaa aika reilusti, mm. tuon langanvetojärjestelmän säätö siten että potentiometri toimii manuaalitilassa absoluuttisena nopeusasetuksena ja CNC tilassa taasen prosenttisäätimenä, jolloin G-koodissa esimerkiksi syöttönopeus F asettaisi langannopeuden. Täytyy vielä hieman tuumailla tuota, mutta luulisin että noin sen teen, voihan sitä sitten myöhemmin muuttaa jos se ei käytössä toimi intuitiivisella tavalla.

Jossain vaiheessa pitäisi myös vaihtaa nuo DB-9 liittimet pois ja pistää yyksi DB-25 liitin tilalle, niin selviäisi yhdellä ohjauskaapelilla ja saisi lisää johtoja erinäisille ohjaussignaaleille, nyt on tuon PWM säätimen jäljiltä nimittäin kaikki käytetty ja lisää pitäisi saada lähitulevaisuudessa, mm. langannopeuden mittaukseen anturi (takaisinkytkentä), EC-mittarin anturi ja ties mitä muuta uutta tässä keksii.

Older posts «

» Newer posts